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Quick Start Guide for Presenters 
 

Welcome to Electromeet! 
 

Welcome to Electromeet!  Electromeet is a tool that allows you to participate in learning and 

collaboration sessions and receive or provide remote support across the globe, from the comfort 

of your home or workplace. Electromeet is easy to use, effective, and lets you focus on the 

subject instead of the tool. 

About this Guide 
This guide is intended for Presenters of Electromeet who require basic working instructions for 

joining, presenting, or moderating Electromeet sessions.  Participants who join Electromeet 

sessions will expect the Presenter to have a reasonable working knowledge of the software – this 

guide serves as an introduction.  We recommend that Presenters also review other guides 

available in the Help section of the website. 

 

Terminology 
Understand these and you‟ll be well on your way to understanding Electromeet. 

 

User – Participant, Presenter, Provider and anyone who wants to use Electromeet for their 

eLearning and collaboration 

Session – any Session where Participants need to be invited by a Provider before joining. 

Typically sessions are part of a paid-for course or are offered in house by an employer, employer‟s 

supplier, or institution. 

Provider – company, institution or individual who establishes and administers session(s) for 

Participants.  A Provider Licence is required. 

Provider ID –Name that is used by the Provider when acquiring a Licence 

Master Password – Supplied to the Provider‟s Main Contact with any Provider licence. It 

provides full access to the Provider Log In pages on the website.  This includes access to the files 

of recorded sessions. 

Access Key – a small file sent to Participants and Presenters via a link in an email.  The Access 

Key provides access to a session. Presenters have a special Access Key which provides special 

permissions in Electromeet. All Participants except the Presenter use the same Access Key. 

Participant – learner, colleague, associate or anyone who wants to join a session. 

Presenter - guide, teacher, instructor or anyone who shares the presentation role during a 

session. 

Virtual Room – the secure place on the Electromeet central computer where sessions can be 

hosted by a Provider. 

 

And terms that are useful for Providers: 

Provider Licence – gives the Provider permission to use a „virtual room‟ to hold sessions for a 

certain number of Participants for up to 12 months. It is like “renting” an Electromeet virtual 

room. For example, a 20 user licence allows sessions for a group of up to 20 Participants to be 

held non-simultaneously over 12 months.  Providers can operate sessions 24 hours, 7 days and 

give Access keys to whoever they wish to invite. 

Licence Versions – The free trial license lasts for 30 days. Other licences last for 12 months. 
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System Pre-requisites for Electromeet 
 

Before installing Electromeet, ensure that your system meets the followings prerequisites: 

 

 
Supported Operating 
Systems 

 

- Microsoft®  Windows 2000* 

- Microsoft®  WindowsXP Home* 

- Microsoft®  Windows XP Pro* 

- Microsoft®  Windows 2003 Server* 

- Microsoft®  Windows Vista 

 

 
System Requirements 

 
Minimum: 400 MHz Pentium Processor with 256 MB of RAM and 
9MB hard disk space. 

 

Microsoft® .NET Framework must be installed on the system.  
 
Note: Most versions of the Windows systems have the .NET 
framework installed by default. If your system does not have 
the framework installed, or if your are not sure, run the 
Microsoft® Windows update available at: 
http://www.microsoft.com/downloads/details.aspx?FamilyId=3

33325FD-AE52-4E35-B531-508D977D32A6&displaylang=en 
 

 
Internet Connection 

 
- Recommended: Cable modem, ISDN, DSL – Supports audio 
conferences, and text messaging. 

 

- Basic: Reliable 56k dial up - For listening to the Presenter 
and sending text messages only. Does not support two-way 
audio conference with the Presenter.  
 

 
Firewall configured to 
allow Electromeet 

 
Participants using a corporate network should consult with the 
system administrator before proceeding to ensure that firewall 
access is enabled. 
 See the document “Electromeet Participant Guide – 
Optimising Your Internet Connection” available from the 
Electromeet website. 

 

 
Audio Prerequisites 

Sound card with latest drivers. 
For sound play back and speech (essential for Presenters): A 

simple, working headset with earphone speakers and an 
attached microphone, connected to your computer (or) A 

separate microphone and computer speakers. If you are using 
a separate microphone, enable echo cancellation from 
Audio>Settings 
 
See the document “Electromeet Participant Guide – 
Optimising Your Audio” available from the Electromeet 

website. 
 

 

http://www.microsoft.com/downloads/details.aspx?FamilyId=333325FD-AE52-4E35-B531-508D977D32A6&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=333325FD-AE52-4E35-B531-508D977D32A6&displaylang=en
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Install Electromeet 
Download the latest version of Electromeet from:http://Electromeet.com/Download/  

(Click on the link above or cut and paste it into your browser.) 

 

Download File Size: 5 MB approximately.  Space required: approximately 12 MB. 

 

Installation Time: Approximately 2 minutes (Depending upon the connection speed) 

 

To install Electromeet on your system 

 

1. After the Electromeet download is complete, double-click on the .zip file, and double click 

on the setup.exe file in the zip file.  

The installed software creates an Electromeet icon on the desktop. 

2. To check if Electromeet has installed successfully, double-click on the Electromeet desktop 

icon. If the Electromeet interface screen launches, you have installed Electromeet 

successfully. However, you will not be online in the session until you launch 

Electromeet with your Access Key.  For more information about joining a session, see Join 

a Session as a Presenter (below) 

 

Notes: 

 To view the version of Electromeet currently instsalled on your system, launch Electromeet 

from the desktop icon, and click Help>About. 

 After you have installed Electromeet, it will automatically update to the latest version of 

Electromeet when available. Electromeet displays an update message after you launch and 

when a new version is made available by the Electromeet team. 

http://iquokka.com/Download/
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Join a Session as a Presenter 
You are a few steps away from joining and presenting a session in Electromeet. 

 

Step 1: Receive eLearning Session Invitation email for Presenters. 

As the first step towards joining an Electromeet session you will receive an email from the 

Provider.  The email will provides a special Access Key that will permit you to join an Electromeet 

session with Presenter privileges. 

 

The email will include details about the session such as the name of the learning session, the date 

and the time for the scheduled session.  The email may also include specific joining instructions 

for the session as determined by the Provider. 

 

The email may also provide you the Participant Access Key link for Participants in your session. 

The Participants individually receive the Access Key link via email. However, if a Participant 

contacts you for a copy of the Participant Access Key, you can send them the Participant Access 

Key by copying and pasting the Participant Access Key link in another email and sending it to 

them. 

 

Step 2: Set your calendar to block time for the scheduled session.  

The eLearning Session Invitation email shows the scheduled GMT time for the session. To know 

the local time at which the scheduled session begins for you, see: 

http://www.worldtimeserver.com/meeting-planner.aspx 

 

Step 3: Ensure that your system meets the prerequisites for participating in a session 

with Electromeet. 

 

Step 4: Check your audio, and system settings well ahead of joining the session. 

Before the session, ensure that your headphone and microphone are working. Go to Control 

Panel > Sounds & Audio Devices and run the audio test wizard. 

 

Note: For detailed instructions about configuring audio for an Electromeet session, see 

the Electromeet Participant Guide-Optimising Your Audio, available at the Help & 

Support section on the Electromeet website. 

 

Step 5: Save (or) open the Access Key in the Session Invitation Email 

To Save the Access Key from your Invitation Email, click on the Access Key link to download the 

Access Key file before the session and note the folder where you saved it. 

 

Alternately, you may choose to Open the Access Key from the link in the session invitation mail 

just before the session starts. Opening the Access Key launches Electromeet into the session if the 

session is scheduled at that time. 

 

Step 6: Join the session a few minutes ahead of the scheduled session 

If you have not already launched Electromeet from the desktop icon, opening the Access Key will 

automatically launch Electromeet into the scheduled session.  Double click on the Access Key file 

that you saved in Step 5, or Open the Access Key directly from the link in the email. 

http://www.worldtimeserver.com/meeting-planner.aspx
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If you launch Electromeet from the desktop icon, go to File>Open Live Session and navigate to 

your saved Access Key. After a short delay, the Join Session dialog appears. In this dialog type 

your full name, then click OK or press Enter. The name you enter is displayed as your name in 

the Participant Info window on the Electromeet interface. 

 

You have now joined the Electromeet session successfully! Welcome to your first 

Electromeet session! 

 

To check your speaker and microphone volume while waiting for the session to start , select Tools 

> Audio Wizard.  

 

Note: For information about interacting with the Presenter and other Participants during 

Electromeet sessions, see the Electromeet Participant Guide-Interacting During an Electromeet 

Session available at the Help & Support section on the Electromeet website. 
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Present an Electromeet Session 
As a Presenter, your participation in an Electromeet session may include presenting, moderating, 

and facilitating the Electromeet session. 

 

Managing Audio 
Before joining an Electromeet session, you must ensure that your system meets the pre-requisites 

for sound playback and speech.  After connecting and testing your headphone and microphone to 

the system, you are ready to present a session on Electromeet. 

 

You can talk to the Participants in an Electromeet session.  The Presenter has administrative 

privileges to prevent the Participants from speaking at any time during the session. 

 

To talk to Participants in Electromeet: 

 

1. Click on the red “Push to talk” button.  

When this button transforms into the green “Talking” button, your microphone becomes 

active and you can talk. 

 

The name of the person who is “Now Talking” appears next to the Push to talk button and 

a green icon covers the speaker icon in the Participant Info window.  If your microphone 

is disabled when the green Talking button is active, click the Audio tab and ensure that the 

Enable Audio checkbox is enabled. 

 

2. When you are not talking remember to click the green Talking button to release it. 

 

 

Disable or Enable Audio for Participants 

Presenters can disable or enable audio for the Participants during an Electromeet session.  By 

default, all Participants can speak during the session.  

 

Management of Participants’ speech 

The Participants press the Push to talk button to speak to the group during the session.  The 

Presenter‟s microphone always has priority.  This means that when a Participant clicks the Push to 

talk button, they will see the button turn to Yellow and be queued to talk only when the 

Participant or the current speaker finishes speaking and releases the green Talking 

button.  You will see a flashing notice in the Participant Info window to warn you of Participants 

who are queued to talk.  The list appears in the order that they joined the queue.  Only the 

Presenter sees the queued list. 

 

If a Participant is talking the Presenter can interrupt by pressing the Push to talk button – this 

interrupts their speech. 

 

To enable or disable speech for all the Participants 

Go to the Participant Info window, then locate the checkbox beneath the Push to Talk button, 

labelled “Enable Participant Speech”.  Uncheck the box to block talking by all Participants.  You 

may need to use your mouse cursor to drag the window just below the Participant Info window 

downwards in order to reveal the checkbox. 
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You can choose to enable this checkbox when you are open to questions from Participants during 

the session. 

  

To enable or disable speech for specific Participants 

1. If all Participants have speech disabled (as above), you can enable speech for a selected 

Participant. 

2. Point to the selected Participant in the Participant Info window, and click the name once to 

highlight that name. 

3. Right-click against the name of the highlighted Participant.  A menu appears. 

4. Select the Give Voice to Selected option to turn on that Participant‟s speech facility. 

5. From the same menu, you can also turn off audio (both speech and sound) completely for a 

selected Participant by clicking Disable Audio for Selected.  To re-enable audio for the 

Participant, select the Enable Audio for Selected option.  

 

Using the Whiteboard 
Note:  Slides, drawing and text messages left in Electromeet after a session will remain 

there until cleared.  To clear these items go to Sessions>Session Reset. 

 

You can load the slides and images to the Whiteboard.  To load the file, click Load File> Open 

Presentation (or Open Image), and load the required files.  Allow a minute or two for the slides 

to be uploaded to the Electromeet remote server then reappear on your whiteboard screen and 

the screens of Participants. 

 

You can navigate through the slides by using the Slide Show controls for Start, End, Back, and 

Forward. 

 

Use the drop down menu to the right of the fast forward control to jump quickly to a particular 

slide. 

 

You can add individual slides at anytime – these will appear at the end of the existing slides, but 

you can jump quickly to any slide using the drop-down menu.  Click the “+” key to add a blank 

slide. 

 

Use the Whiteboard Tools to the left of the whiteboard to add text, add shapes, draw, highlight, 

and erase contents on the whiteboard.  Select Colours and Fonts using the selector at bottom 

left of the whiteboard. 

 

Participants do not have access to the Whiteboard tools unless you permit access.  You can 

disable, or enable the Participants access to the tools.  To control access to the whiteboard, select 

the Participant name in the Participant Info window and click it to highlight the name.  Right-

click on the highlighted name and select “Enable Whiteboard for Selected”.  Remember to 

disable this when finished. 
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Send Text Messages 
You can send to and receive text messages from all the Participants, or individual Participants in 

the session.  The Text window displays the text messages that you send and receive. 

 

Note: Presenters can allow Personal (private) messages by checking the “Enable 

Private Texting” checkbox, located just below the text tools icons in the Text window. 

 

To send an instant text message: 

 

1. Click the Text tab. The Text window appears (this window appears by default when 

Electromeet is launched). 

2. Select the recipient of the text message in the drop-down list (the names of the online 

Participants are displayed in the Participant Info window.).  Default is for messages to be 

sent to All Participants. 

3. Type the text message in the Text Box, and press ENTER or click Send to send the text 

message to the intended recipients. 

4. You can change the font, the font style, or the font size by clicking the Change Font icon. 

5. You may also enter emoticons by using Emoticons drop-down list, and select the required 

emoticon. 

6. Turn on an indication of the time when text messages are sent by clicking the Show/Hide 

timestamps icon. 

7. To insert an image file in the message while typing, click the Insert Picture icon, and 

specify the file. 

8. You can turn on audio narration of your text messages  with the Narrate messages icon.  

You alone will be able to hear the narration (Participants would need to turn on this feature 

at their own computers). 

 

Recommended: Click on the Text tab to ensure that the Text window is visible at all 

times during the eLearning session. This will enable you to view all the text messages 

that are sent to you by the Participants immediately. 

  

Note: You have administrative privileges to prevent the Participants from sending text 

messages anytime during the session – see Note above. 

 

View Participant Communication 
You can view the list of other users who are online in the Electromeet session on the Participant 

Info window. The Participant Info window provides the following communication options.  Each 

option appears in a column next to the Participant‟s name. 

 

Participant Name 

Displays the names of the users who are currently online on the Electromeet session. 

 

Raised Hand 

Displays if the Participants have raised their hands to communicate with the Presenter. 

Participants can click the Raised Hand icon below the Participant Info window to request 

permission to communicate with the Presenter. When Participants click the Raise Hand icon again, 

the raised hand returns to the normal default position, and closes the request for communication 

with the Presenter. The Presenter can see the enabled Raised Hand icon and can also hear an 

audible beep when you click the Raised Hand icon. 
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Communications 

Other columns in the Participant Info window let you view the communication settings for audio, 

video, and text messaging for all the users on Electromeet.  When a Participant is speaking a 

green highlighted item will appear over the audio (speaker) icon.  When a Participant‟s video 

camera is active a red highlight will appear over the camera icon.  When a Participant has sent a 

text message the text icon will show an opened envelope. 

 

Whiteboard Tools 

This icon shows if the tools for editing the whiteboard contents are available for your use.  If the 

Presenter does not grant permission to edit the whiteboard, this option is disabled for Participants. 

 

Emoticons 

This column is blank until you select an emoticon from the drop-down menu in the Participants 

Info window.  These emoticons allow Participants to express comprehension of the presented 

information and to provide instant feedback to the Presenter. The Participant Info window lets 

you view the emoticons of other users in the session.  

Moderate Participant Communication 
You can allow or revoke audio, video, messaging, and whiteboard editing privileges for the 

Participants from the Participant Info window. 

 

Highlight a selected Participant‟s name.  Right-click against the highlighted name and select the 

rule to allow or revoke the communication privileges.  For example, from this menu you can select 

the Give Voice to Selected option to allow a specific Participant to talk in the session, even 

though you may have disabled “Allow Participant Speech”. 

 

You can also select multiple Participants and apply the rules for allowing and revoking 

communication privileges. 

 

To revoke speaking privileges for all the Participants, disable the “Enable Participant Speech” 

option under the Push To Talk button. 

 

Conduct a Web Tour 
The Presenter can launch a web tour using the specified tool in the whiteboard tools.  Click the 

Web Tour icon and the Web Tour window will launch.  Enter the web address of the site you want 

to visit, and click “Take all To Page”.  A remote window will automatically launch on Participants‟ 

computer screens and will show the site you have entered.  If you navigate away from the site 

you must always click “Take All to Page” to refresh the remote windows on Participants‟ computer 

screens. 

 

Note that Participants will be able to navigate way from the page you are showing from within the 

remote window on their screens.  You can force a return to the page you want to show when you 

click “Take All to Page” on your screen. 

 

To finish the web tour, close the Web Tour window. 
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Polls and Questions 
The Presenter can use pre-prepared slides to elicit responses from Participants, or develop 

questions “on the fly”. 

 

Questions can have up to 5 responses (A, B, C, D, E). 

 

To ask a question, click the New Question icon in the Whiteboard Tools to open the Questions 

window.  If you have pre-prepared a slide with a question, select the Current Slide tab then click 

OK.  This will cause 5 boxes to appear at the bottom of the whiteboard of Participants.  

Participants can then click on the box of choice, then only the Presenter will see the response next 

to the Participants‟ names in the Participant Info window. 

 

If you want to ask a new question, click the New Slide tab in the Questions window, type your 

question then the alternative responses, click the Correct response button, then click OK.  A new 

slide will be visible to Participants showing the question and 5 possible responses (A, B, C, D, E).  

Participants should click their chosen response, and their response will be seen only by the 

Presenter next to their names in the Participant Info window. 

 

Share Desktop 
The Presenter can share the desktop of their computer system with all Participants.  Control of the 

desktop remains with the Presenter unless passed to a Participant. 

 

Note: Desktop Sharing is an advanced function and practice is recommended before 

using the feature. 

 

To start desktop sharing: 

1. Highlight your Presenter name in the Participant Info window.  Right click the highlighted 

name, and select Start Desktop Sharing from the menu.  The Sharing window appears 

at the whiteboard. 

2. Follow the Steps in the Sharing wizard, then click Start.  A Remote Window appears on 

the screens of Participants that will show the contents of your desktop and any applications 

running. 

3. You can use the wizard to pass control to a selected Participant.  To regain control, click 

the Me button, or press your Esc key twice. 

4. Click Cancel to stop sharing your Desktop. 

 

Record the Session 
It is possible to record activity in an Electromeet session.  Please see the guide “Record and 

Playback a Session” in the Help section of the website. 

Leave the eLearning Session 
 

When the session is finished, click on the Close Window, “X”, icon at far top right of the 

Electromeet interface to quit the session. You can also log out by clicking the Log Out door icon 

below the Participant Information window. 

 

Note:  Slides, drawing and text messages left in Electromeet after a session will remain 

there until cleared.  To clear these items go to Sessions>Session Reset. 

 


